Saturday 19 March 2016

Compatible Arrays


2 arrays are said to be compatible if they are of the same size and if the ith element in the first array is greater than or equal to the ith element in the second array for all i.Write a program to find whether 2 arrays are compatible or not.

Input Format: 
Input consists of 2n+1 integers. The first integer corresponds to ‘n’ , the size of the array. The next ‘n’ integers correspond to the elements in the first array. The last 'n' integers correspond to the elements in the second array. Assume that the maximum value of n is 15.

Output Format: 
Refer sample output for details. Sample Input 1:
5
2
3
6
8
1
1
1
1
1
1

Sample Output 1:
Compatible

Sample Input 2: 
5
2
3
6
8
1
1
1
1
1
2

Sample Output 2:
Incompatible

Code:
  #include<stdio.h>
int main(){
  int n,a[20],b[20],i,flag=0;
  scanf("%d",&n);
  for(i=0;i<n;i++)
    scanf("%d",&a[i]);
  for(i=0;i<n;i++){
    scanf("%d",&b[i]);
    if(a[i]<b[i])
      flag=1;
  }
  if(flag)
    printf("Incompatible");
  else
    printf("Compatible");
  
  
  return 0;
}

2 comments: