Monday 14 March 2016

Pattern 10


Write a program to print the given pattern.

Input Format: 
Input consists of a single integer.

Output Format: 
Refer sample output. There is a trailing space at the end of each line.

Sample Input: 
5
Sample Output:



1 1 1 1 1
2 2 2 2
3 3 3
4 4
5

Code:
  #include<stdio.h>
int main()
{
  int n,i,j,k=1,x;
  scanf("%d",&n);
  x=n;
  for (i=1;i<=n;i++)
  {
    for(j=1;j<=x;j++)
    {
      printf("%d ",k);
    }
    printf("\n");
    k++;
    x--;
  }
  
  return 0;
}
      

No comments:

Post a Comment