Saturday 19 March 2016

Sum of array elements


Write a C program to find the sum of the elements in an array.

Input Format:

Input consists of n+1 integers. The first integer corresponds to ‘n’ , the size of the array. The next ‘n’ integers correspond to the elements in the array. Assume that the maximum value of n is 15.

Output Format:
Refer sample output for details.

Sample Input 1: 
 5
 2
 3
 6
 8
 1

Sample Output 1: 
The sum of the elements in the array is 20

Code:

  #include<stdio.h>
int main(){
  int n,i,a[20],sum=0;
  scanf("%d",&n);
  for(i=0;i<n;i++)
  {
    scanf("%d",&a[i]);
    sum=sum+a[i];
  }
  printf("The sum of the elements in the array is %d",sum);
  return 0;
}
  

2 comments:

  1. n=int(input())
    li=[]
    for i in range (n):
    x=int(input())
    li.append(x)
    print(sum(li))

    >>20

    ReplyDelete